Last Reviewed 08/03/2015

Versions 6.0,6.1,7.0


This article lists the requirements for viewing Mediasite content on all supported platforms.



  • Microsoft Windows 10, Windows Server 2008 (requires the Desktop Experience), Windows 8, Windows 7, Windows Vista
  • Microsoft Edge, Microsoft Internet Explorer 7.0 or later (IE8 or later required if using the Mediasite 7 multiview player), Mozilla Firefox, or Google Chrome
  • Windows Media Player 9.0 or later (IE only)
  • Adobe Flash for Smooth Streaming playback in Chrome (Mediasite 7.0.23 and later); Microsoft Silverlight 5 for Smooth Streaming playback in all other browsers
  • Broadband Internet connection

Note: Enterprise Video Platform 7.0.25 or EX Server 6.1.23 are required for Windows 10 support.



  • Mac OS X 10.5.7 or later
  • Apple Safari, Mozilla Firefox, or Google Chrome
  • Microsoft Silverlight 5.0 or later (viewers are prompted to install this when attempting to view a presentation)
  • Broadband Internet connection



For detailed information on Linux support, please see KBA3323.

Additional Comments


How would you rate this article?

Thanks for voting!