Created 8/31/2011
Last Reviewed 9/14/2020
Versions 7.4

Issue

This article lists the requirements for viewing Mediasite content on server version 7.4.

Solution

Microsoft Windows

  • Microsoft Windows 10
  • Microsoft Edge, Mozilla Firefox, or Google Chrome
  • Broadband Internet connection

Apple MacOS

  • Apple MacOS Mojave (version 10.14) and higher
  • Apple Safari, Mozilla Firefox, or Google Chrome
  • Broadband Internet connection

Apple iPadOS

  • Apple iPadOS 13 and higher
  • Apple Mobile Safari
  • Broadband Internet connection

Apple iOS

  • Apple iOS 12 and higher
  • Apple Mobile Safari
  • Broadband Internet connection

Android

  • Android 9 or later
  • Chrome browser

Linux

For detailed information on Linux support, please see KBA3323.

Feedback

How would you rate this article?

Loading
Thanks for voting!